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Special thanks to Kristine Lund for her help in the tranla-
tion.

THE AUTHOR MAKES NO WARRANTIES, EXPRESS
OR IMPLED, INCLUDING WITHOUT LIMITATION
THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS FOR A PARTICULAR PURPOSE, REGAR-
DING THE SOFTWARE.

IN NO ENVENT WILL THE AUTHOR BE LIABLE TO
YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR
INDIRECT DAMAGES (INCLUDING DAMAGES FOR
LOSS OF BUSINESS PROFITS, BUSINESS INTERRUP-
TION,...) ARISING OUT OF THE USE OR INABILITY TO
USE THE SOFTWARE. BECAUSE SOME JURISDIC-
TIONS DO NOT ALLOW THE EXCLUSION OR LIMITA-
TION OF LIABILITY FOR CONSEQUENTIAL OR
INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS
MAY NOT APPLY TO YOU.

You may not: modify, reverse-engineer, disassemble,
decompile or reduce the software to a human perceivable
form or translate, sub-license, resell for profit, lend, or
leave any portion of the software.
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Preface

1. About this manual

This is the manual for version 2.6 of Macao software, a
graph editor for the Apple Macintosh computer. The first
chapter “Stand Alone Macao” gets you started creating,
editing and printing graphs on a stand alone machine.
The second chapter, “Connected Macao” details the use of
Macao in connection with the AMI (Analysis, Modeling
and Integration) environment of the MARS Project
(Methods and Analysis for Reliable Systems). You can
also use Macao in connection with AMI version 2 (also
called FrameKit).

Differences between this version of Macao documentation
and the previous one are outline by change bars. See on
the right.

2. Before you start…

Learning Macao is easy because it follows the Human
Interface Guidelines described in the Apple Desktop
Interface and used in numerous other software.

This manual assumes that you are familiar with terms like
finder, dialog box, menu and that you know how to use
the mouse to select, click and move windows. These
topics are covered in the owner’s guide of your Macin-
tosh. (published by Apple Computer, Inc.)

3. Configuration

To use Macao, you need :
• any Macintosh or compatible computer (Macao

does not run on a Macintosh Plus, Macintosh SE,
Macintosh Classic, Powerbook 100 or any Macin-
tosh with a 68000 processor),

• a Sparc Station (Solaris 2.3 or higher) or an Hewlett-
Packard station (HP-UX 9.01, 9.03 or 9.05) with
MAE 2.0.2 (Macintosh Application Environment)
from Apple Computer,
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• MacOS 7.0 or higher.

The use of a color screen is better for some graphic mani-
pulations.

4. FTP site

Macao is licensed free of charge for use in educational and
non-profit organizations.

The official anonymous FTP site for Macao is:

ftp://ftp.ibp.fr/ibp/softs/masi/ami/binaries/
interface

and

ftp://ftp.ibp.fr/ibp/softs/masi/ami/documenta-
tion/interface

for its documents. 
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Stand-alone Macao

1. Introduction

Macao is a graph editor. Its functionalities are described in
this first chapter (Stand-alone Macao). Each type of graph
is characterized by the type of nodes, edges and labels
associated with it. This is called the graph’s formalism.
Formalisms are defined externally in files.

You can distinguish Macao from other graph editors by its
configurability. It offers the same functionality for every
formalism which decreases the learning time and the risk
of mistakes. Macao lets the user change parameters and
aesthetic attributes of objects. Macao allows user interacti-
vity and is perfectly suited to the user environment.

Macao can be connected to a Unix system (cf “Open a con-
nection”, page 31) and in doing so becomes the user inter-
face of a set of applications to make calculations on graphs
called models.

2. Introduction to Macao

The goal of this chapter is to introduce the use of Macao
with examples. The major concepts and the principal
functionalities of Macao are described.

Let us see how to start Macao.

2.1. Start up the Macintosh
If you’ve got Macao on a disk, insert the Macao disk into
the disk drive. The disk contains the Macao application
(Macao file), formalism files (for example AMI-Net or
Graph) and example files. Copy these files onto your hard
disk.

A formalism file contains the description of each kind of
node, edge and associated label.

2.2. Open the Macao Application
Open Macao with a double-click.

Macao AMI-Net

Example
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The Macao menu bar appears.

After a welcome message, the service window comes up.
The window name is historic.

Macao uses the service window to inform the user of cer-
tain events (errors, different steps). It is especially useful
when you use Macao in AMI as it receives textual results
from applications and maintains historical commands (cf
“Textual results”, page 35). Messages begining with # are
Macao’s internal errors. If you know how to reproduce
them, please send a mail to macao@masi.ibp.fr.

You are ready to work with Macao.

The Apple menu ( ) gives information about Macao and
gives you access to desk accessories and Apple menu fol-
der items.

The File menu allows file manipulations and printing
from Macao. The Edit menu gives standard Macintosh
operations like Cut/Paste, Copy and graphical manipula-
tions.

Macao 2.6

By Jean-Luc MOUNIER

June 20th, 1996

MASI LABORATORY
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The View menu will be described in the section: “Views”,
page 27.

The Text menu will be used to change text styles.

The AMI menu will be used for the connection to the spe-
cification environment (cf “Run a service”, page 33). If it
does not appear please see “Register”, page 32.

2.2.1. Create a model
You can create a new model from the File menu.

A model represents data from the user. It can be a problem
description that can be solved by the AMI environment, or
a result created by the environment. Every model has
been described by means of the basic objects of a forma-
lism.

2.3. Choose New from the File menu
A dialog box appears, this occurs when Macao needs
more information to complete a command. Here, you’ll
have to choose the formalism of your new model from the
formalism files proposed by Macao. The dialog box shows
formalism files or folders and allows you to browse
through the file hierarchy using the standard Macintosh
techniques.

2.4. Choose a formalism
Choose a formalism (AMI-Net for example) and click on
the open button. A new window appears in which you will
draw your model.

The toolbox, in the upper right corner of the screen, con-
tains tools and graphic formalism objects. It consists of
four groups: the first for the basic tools, the second and
the third are for the formalism’s objects, the last one for
intermediate point tool for the edges. The lower part of
the palette is the identification zone. It contains the name
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of the graphic tool currently selected. Now it is the arrow-
pointer Select.

• The first group are basic tools for the graph manipu-
lation (The selection tool and the label tool ).

• The second group contains the formalism nodes
(place, transitions,… for the Petri net example).

• The third group defines the edges.
• The last icon is the intermediate point tool for the

edges.

Notes: The toolbox is a floating window, this means that it
is always in front of the other windows and can be put in
any place on the screen. You can recognize floating win-
dows by their special smaller title bar.

The model window contains the new document. The title
bar contains the name of the file. This name is suffixed by
.Root.1 which means that it is the first window on the root
page (cf “Results of a service”, page 34).

This window contains:

The editing zone contains one object: the information
object. It cannot be deleted but will not be copied nor
print.

Toolbox

• An editing zone,
• thetitle bar,
• the two scrolling bars,
• the zoom box (top right corner) that changes the size

of the window to the size of the screen,
• the close box,
• the location icon lets you know where your window

is positioned in the whole model (“The location
icon”, page 27).

• the pencil icon indicating if the user is able to
modify le model,

• the grow box (right corner button) that lets you
change the size of the window,

• the state bar lets you know the type of the current
selected object or label,

• the grow and reduce icons.

Macao
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This object groups together general information about the
model, like its title, the author’s name or specific informa-
tion for the formalism. For example:

The name of the service window is the name of the cur-
rent edited model.

2.5. Draw a model
Everything is ready for the creation of a new model.

Example : let us edit a model in the colored Petri net for-
malism (AMI-Net). Such a model will be composed of
nodes (places and transitions) and edges (arcs).

To create an object, you have to select it in the object area
of the toolbox.

2.5.1. Select the place object
To select the place object, put the cursor on the first icon of
the second group of the toolbox by using the mouse, and
click.

You can observe:
• A modification of the cursor that now looks like the

selected object. 
The selection continues as long as the user does not
select another object in the toolbox.

• The indication of the type of the selected object
(place in this case) in the identification zone of the
toolbox.

Let us start by drawing places.

2.5.2. Draw the place object
Place the cursor anywhere in the editing area of the model
window, and click.

A place has been drawn. The circle that represents it is
drawn with a bold line (in red on a color screen). It
remains selected.

The state bar at the bottom of the model window is filled
with the type of the selected object.

We are going to draw a second place. As the cursor still
looks like a circle, we do not need to select the place object
from the toolbox.

Place the cursor somewhere else in the editing area of the
model window and click. A second place has been drawn.

We now need to edit a transition.
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2.5.3. Select the transition object
By using the mouse, put the cursor on the second icon of
the second group of the toolbox and click.

Place the cursor in the editing area of the model window
and click. A transition has been drawn, represented by a
rectangle.

Three nodes have been created in the editing area of the
model window. We are now going to link the transition to
the output place. To do so, we need to select the arc object
from the toolbox.

2.5.4. Draw arcs
By using the mouse, put the cursor on the first icon of the
third group of the toolbox and click.

The cursor now looks like an arrow. Editing an arc
between two objects consists of drawing a line between
the source object and the destination object. Place the cur-
sor on the transition, then push the mouse button and
move the cursor to the place (without releasing the but-
ton) until the place has been selected. Release the mouse
button. The arc becomes the selected object.

In case of error (starting or arriving out of a node, connec-
ting incompatible nodes) you will hear a beep.

An arrow is automatically drawn at the end of the arc.

The arc now starts from the middle of the transition (con-
nection point) and arrives on the edge of the place. The
connection points are automatically computed and re-eva-
luated each time an arc is added or deleted.

Remark : Macao controls the compatibility of the source
and destination nodes for every type of edge. This infor-
mation is part of the description of the formalism.

For another arc, place the cursor on the transition, then
push the mouse button and move the cursor to another
place (without releasing the button) until the place has
been selected. Release the mouse button. 

2.6. Delete objects
The following rules are used each time a graphic object is
deleted, whatever the formalism.

• All the associated attributes are deleted together
with an object. 

• All the edges starting from or arriving to a node are
deleted together with the node. 

To delete all the objects, use the Select All entry in the Edit
menu, then push the Delete key, or choose the Clear entry.



Textual attributes

© 1988-96 Version 2.6 15

2.7. Textual attributes
The definition of a formalism contains a list of textual
attributes associated with nodes and edges, and default
values for some of these attributes. Default values can be
seen by the user when (s)he enters another value.

To preserve their readability, default values are usually
not represented on the model. Nor are they saved, in
order to minimize the size of model files.

2.7.1. Add label to an object
In the former section, we have only presented how to
draw objects. However, depending on the formalism
under consideration, many attributes can be associated
with an object. For instance, in the Petri Net formalism, a
place has a name and a marking.

The user can enter the value of an attribute in two diffe-
rent ways:

• by using the label tool in the toolbox, 
• by means of a dialog window. 

2.7.2. The Label tool
The label tool makes it possible to associate text or a value
to every attribute of an object.

First, the label tool must be selected. Using the mouse, put
the cursor on the second icon of the toolbox and click.

The cursor now looks like a capital ‘T’ associated with an
arrow. You are now in the textual input mode and you
must select an object in the model window.

2.7.2.1. Add a label to an object
Place the cursor on the object, then hold the mouse button
down and drag to the position where you want the label
to appear. Release the mouse button. You can enter text in
the writing area that appears. The size of the area changes
according to the number of characters you enter. 

The state bar at the bottom of the model window is filled
with the name of the attribute being modified.

Note: a label may be composed of several lines. The size of
the writing area will grow according to the size of the text.
To exit the textual input mode, you can push the Enter key.

As you can see, the attribute is the first attribute not cur-
rently filled. If you want to choose another attribute
immediately, push down the Command key before clic-
king. See the next section.

2.7.2.2. Add a specific attribute
Place the cursor on the object, push the command key and
then the mouse button. A popUp menu appears with the
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available attributes for the object. The checked attributes
indicate attributes already entered. Dimmed attributes
cannot be modified. Choose an attribute and release the
mouse button. You can enter text in the writing area that
appears. The size of the area changes according to the
number of characters you enter. 

2.7.3. Choose Attributes from the Edit menu

Select an object in the model window and choose Attribu-
tes from the Edit menu. A dialog window appears. The
window is composed of an Attribute area with every attri-
bute names and an input area where you can change the
attributes values. The name of the window is the name of
the objet or its internal number(1).

You can now update the attributes of the object.

To change an attribut’s value, clic the attribut name in the
Attribut area, then clic the Value area. The modification of
an attribute is done by entering a string. The modifica-
tions are validated by clicking the OK button. In case of
error when entering information, click the Cancel but-
ton(2).

You will have more information in “More about textual
attributes”, page 23.

The model is now partially described.

The document can be saved to a file by means of the usual
commands in the File menu of the Macintosh.

(1) Every object has an internal number in Macao. This number identifies the
object.

(2) In every dialog window, according to the style guide of the Macintosh user
interface, the Esc key is equivalent to Cancel and the Enter key is equivalent to
OK.
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2.8. Save a document
Macao uses the standard Macintosh functions for saving
work during or at the end of a session. You can use com-
mands Save or Save as from the File menu. You can also
simply close the model window or quit the application
and you will be prompted to save.

2.8.1. Choose Save from the File menu
When you save a model for the first time, you’re asked to
give it a name.

Note: when you save a file again, Macao temporarily
saves the file in the Tempory Items folder located at the root
level of the volume, then it copies the file in the correct
location. In case a problem arises while saving the file, the
old file is still there. If there is no problem, the tempory file
is deleted automatically.

When your file is saved, you can either keep on working
on the model (section 3., page 17) or quit the application:
while choosing Quit from the File menu.

In this section “Introduction to Macao”, we have introdu-
ced the basic facilities of the graph editor. Macao offers
many other possibilities that we describe in the next sec-
tion.

3. Graphic manipulation

3.1. Use the magnetic grid
Macao offers a magnetic grid that allows you to automati-
cally create aligned objects. The grid can be temporarily
desactivated by using the Magnetism entry in the Edit
menu. When the grid function is activated, not the edges
but the centers of the objects are aligned. The horizontal
and the vertical definition of the grid can be separately
modified.
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3.2. Reorganize connection points
Macao lets you place nodes and draw edges. Your work
will be simpler because Macao automatically takes cares
of anchored points on nodes. To achieve this, Macao com-
putes several algorithms depending of the form of each
node. These predefined algorithms are a part of the aes-
thetic of a formalism.

When nodes are circles, the arc is drawn in the direction of
the center of the node.

When the node is a rectangle, Macao dispatches anchored
points along the nearest border.

In the figure, on the left, object 1 is linked to object 3. The
anchored point is exactly at the middle of object 3. When
you link object 2 to object 3, the arrow moves so that the
two edges are regularly dispatched on object 3.

In the third case, moving object 2 to the left of object 1
implies a permutation of the two edges.

In the last case, objects one and three are aligned. The con-
nector has the priority over the other connectors at the
moment of the anchorage point’s calculation. The connec-
tor coming from object 1 is therefore in the center of object
3 and the other connector is placed in the center of the
remaining space.

Anchored points are automatically computed when
objects are modified or when intermediate points or edges
are created.

3.3. Move objects

3.3.1. Move manually
To move a set of objects, you must first select them, then
click an object of the set and drag it to its final position
before you release the mouse button. While you are drag-
ging the objects, Macao computes the edges of every
node, and these edges move in real-time with the mouse.
The edges linking the dragged objects with objects that
have not been selected move accordingly. This operation
gives the user a visual feed-back.

3.3.2. Using the keyboard to move
Objects can also be moved by means of the keyboard
arrows. This is the best way to obtain a horizontally or
vertically precise movement. The step of the move is one
grid unit. To move more quickly, press shift and the appro-
priate arrow key.

3.4. Intermediate points
Macao lets the user create intermediate points on edges.
To get such an intermediate point, you have to select the

1 2 2

2

1

1

3

33

2

1

3

➀ ➁
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edge and pull it to the desired position. The intermediate
point remains selected and looks like a small red square
(black on a black and white screen).

.The figure below shows the creation of two intermediate
points, one on the bottom and the other on the top.

There are two ways to delete an intermediate point:
manually or automatically. To do it manually, just select it
and press the delete key. Automatic deletion is explained
cf. “Intermediate points”, page 24 in “High level func-
tions”

3.5. Align
Object alignment is an essential feature for aesthetic net
design. Most of the tools provide this by means of a grid
or a set of specific alignment commands. Macao improves
these functions while taking into account the graph’s par-
ticularities and the users’ habits.

Drawing programs provide a full set of alignment
options. These commands are often complex because they
cannot be supported by the graph semantic. On the other
hand, Macao offers only one command: “Align”. Howe-
ver, the program deduces the user’s intention. For exam-
ple, when (s)he selects a set of objects that are roughly
vertically aligned, Macao understands that (s)he wants a
vertical alignment because a horizontal alignment would
put the objects on top of each other. If these objects are
nodes or intermediate points, Macao aligns their center.

Certain objects, like text or intermediate points have the
benefit of a different grid than that of nodes. This grid
allows then to align intermediate points as a function of
anchorage points.

Please note that Macao automatically centers text when it
is moved near the center of a node.

Macao keeps alignment constraints. This means that if the
user moves one of the objects previously aligned, all ali-
gned objects will move together in the same direction (see
figure on the left). Macao remembers every alignment
constraint and moves aligned objects in real time. If you
want to cut the alignment, use the command “Cut the Ali-
gnment” from the Edit menu.
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If you want to temporaly inhibite a constraint, press the
command key ( ) before moving the objects.

4. High level functions

4.1. Choose Copy / Paste from the Edit menu

4.1.1. General copy / paste
Macao allows the user to copy a part of the graph and to
paste it elsewhere. Copy/Paste takes into account the
Macao graph semantic. For example, edges are not copied
unless the beginning and the end objects are copied as
well. A textual attribute will not be copied without its
parent object and if an object is copied all its attributes are
also copied.

4.1.2. Copy / Paste the information node
Cutting and pasting the information node is a specific
case: This object must always be present and you can only
have one object per model. This means that only the infor-
mation node’s textual attributes are pasted.

4.1.3. Paste again
When objects are pasted, they are placed off to one side of
their original objects. When these pasted objects are
moved the objects that are pasted next are placed with the
same distance. This allows objects to be arranged in a
regular manner.

4.1.4. Copy / Paste and formalisms
When part of a model of a formalism is copied, Macao
checks the formalism when it pastes. We cannot therefore
copy one formalism’s model into another one. On the
other hand, it is possible to copy the model of a given for-
malism into a more recent version of the same formalism.
In this way, the formalism of the model is kept up to date.

4.1.5. Copy to another application
cf “Copy to another application”, page 28.

4.2. Choose Duplicate from the Edit menu
If you want to quickly copy objects in the same model,
Duplicate is the good item. You can choose this item seve-
ral times to obtain shift copies.

General rules concerning textual attributes Copy/Paste
are the same for Duplicate but edges and intermediate
points are also duplicate. This allows you to duplicate
objects connected to their environment.

A quick way to duplicate objects is to press the Option key
while moving the objets.
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4.3. Select an object by its name
In order to help the user to find an object whose name
(s)he knows, Macao interprets keystrokes as selectors of
object names. Pressing a, for example, selects all the
objects beginning with the letter a. You cannot however be
in text input mode. Macao sets a timer on keystrokes:
keystrokes in rapid succession form a string; keystrokes
spaced in time are processed separately. Macao produces
a beep as soon as the user types an object’s full name.

4.4. Dispatch
If you select a set of nodes that are vertically or horizon-
tally aligned and choose Dispatch from the Edit menu, all
the nodes will be dispatched regularly from the top to the
bottom (or from the left to the right). Sometimes the dis-
patch won’t be exactly what you expected because the
nodes will be placed on the magnetic grid.

4.5. Modify the look of nodes

4.5.1. Modify the type of a node
Every object in a formalism has an aesthetic part. For
example, the aesthetic part consists of the object size or the
default position of the textual attribute.

The user can modify the size as well as the visualization
position of each of the attribute at his or her convenience.

Using the mouse, position the cursor on the object in the
toolbox that you want to modify. Double click. A dialog
box will appear titled Object Information. 

The modification of the aesthetic part of the formalism is
completely intuitive because Macao gives you the picture
of the object and all of its attributes in their default posi-
tion in one window. The user simply selects the attributes
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and moves them into a new position with each attribute. It
is also possible to associate a typography characterized by
the font and the size.

In the left hand of the dialog box, the object will appear
centered in a frame; the center and bottom right corner are
marked by a square point. Modifying the object’s size con-
sists of moving the point in the corner with the help of the
mouse.

Notes:
1) The modifications are recorded. When the size or

font of an object is modified, all the objects of the
same type in the model are modified.

2) Position modifications of text attributes are not
applied until the next creation of new attributes.

4.5.2. Choose Change size from the Edit menu
If you select a set of nodes of different types, you can
modify their size (horizontal and/or vertical). Choose
Change size from the Edit menu. Macao will draw a dialog
window for every kind of node.

The values are the horizontal and vertical size. Note that
an empty field indicates that the size in not the same for
every selected objects. Default values are defined in the
formalism file and can be changed for a model see
“Modify the type of a node”, page 21.

4.5.3. Direct modification of the size of a node
Macao allows us to punctually modify a node’s size.
Select the node, then re-click in the bottom right corner of
the object and drag until you obtain the desired size.
Macao changes the object’s size and the object remains
centered in its initial position while conserving its align-
ment with the other objects.

Note: If the horizontal and vertical size of the object is
identical (for example a circle), this equality will be con-
served when the size is changed.
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4.6. More about textual attributes

4.6.1. Attribut dialog box
You can select several objects in the model window and
choose Attributes from the Edit menu. Macao will open as
many dialog windows (if it is reasonably small !). Here is
an example.

Tips:
• To pass from one area to the next one, you can use

the Tab key.
• To pass from one area to the previous one, you can

press shift and the Tab key.
• To choose another attribute in the Attribute area

press the appropriate arrow key.
• To choose another attribute in the Value area press

command key and the appropriate arrow key.

4.6.2. The Note area
You can add a note (comment) to any node or edge of a
model. Click the small triangle at the bottom of the Attri-
bute window and type the comment.

Later you can see the note if you activate balloons help
(help key) and move the pointer on the object.
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4.6.3. Text style
In the attribute window, you can change the text styles.
Select the range of text and choose appropiate font, size
and style in the Text menu.

4.7. Intermediate points

4.7.1. Delete
The deletion of intermediate points is done either
manually or automatically. You can manually select the
point and delete it. Otherwise intermediate points are
deleted when they are no longer necessary i.e. as soon as
the point is aligned with two other points of the same
edge. The combination of this functionality with the reor-
ganization of anchorage points simplifies the work of the
user.

Example 1 :

Moving object P to P’ provokes the automatic
disappearance of the intermediate point x.

P
x

P'
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Example 2 :

When object (1) is moved, the anchorage points
are reorganized. This reorganization erases the
intermediate point (a).

Example 3 :

The deletion of the intermediate point (a) provo-
kes an automatic reorganization of the anchorage
points while avoiding the crossing of the two
arcs.

Series of deletions and reorganizations can be combined.

Example 4 :
The example here presents a functionality of
Macao. There is an intermediate point perfectly
vertically aligned with an anchorage point. When
the user moves the object (1), the reorganization
of the anchorage points moves the intermediate
point to the right

4.7.2. Round corners
It is possible to know an intermediate point’s roudness by
asking for Attributs. If the information is asked for while
“Object’s intermediate point” is selected in the palette and
no other object is selected, the then modification will con-
cern the default value of all the intermediate points that
have been and will be drawn. If an intermediate point is
selected, the roundness will concern only that point.

The window below allows the user to change the round-
ness value.

4.8. Model windows

4.8.1. Choose Scale from the Edit menu
The user may work on the entire page; but (s)he may also
see part of the model in a window. The user may also
change the scale of this window.

1

1a

a

1

1
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When the user chooses Scale in the Edit menu, a dialog box
appears, permitting the scale change in the current win-
dow. The user inputs a reasonable value (between 25 and
400%) and clicks OK. The picture in the window adapts
immediately to the new scale.

Note: The item Scale from the Edit menu always follows
the scale of the current window.

4.8.2. Choose New Window from the File menu
If you want to simultaneously see another part of the
model or the same part with a different scale with Macao,
choose New Window from the File.

A window with scale of 100% will appear. You may move
this window where you wish and change the scale size.
Macao gives the window’s name a suffix of “.2” indicating
that it is the second window on the model.

A classic usage would consist of having one reduced win-
dow representing the whole model and one window for
working in detail on one part of the model.

All of the windows are editing windows and everything
that takes place in one window is automatically updated
in the others. Below, a node is moved.

Warning: All of these windows are representations of the
same page of a model. Only the initial page is saved.
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Note: You can make as many new windows as you like on
a given model. The only limit is the available memory.

4.8.3. The location icon
For models that are greater than the screen, it is useful to
locate the picture within the whole page. This is possible
by using the location icon situated at the bottom of the
model window. It shows you what your window position
is with respect to the work space. Click on the location
icon.

All of the nodes and the attributes of the model appear in
a reduced form and a dotted rectangle indicates the win-
dow’s position on the page.

4.9. Views
When building a complex model, the user may find it use-
ful to define different views, hide them, select them and
make them reappear.

The view system is very useful once one the model beco-
mes cluttered, especially if there is a lot of text. Hiding
views permits the user to work on a model that is less
complicated.

4.9.1. Choose Create a View from the View menu
A dialog box appears asking the user to name the view.
The views must all have different names in Macao. Accor-
dingly Macao leaves the button “Create” grey until an
acceptable name is given. Type the name of the view. Click
on create.

Once created, the new view name appears at the bottom
of the view menu.

Afterwards, when the view is selected, the objects of the
view will appear selected.

4.9.2. Choose Show and Hide View from the View
menu
The View menu has two hierarchical menus; Show a view
and Hide a view. These two menus, show and hide views.
Logically enough, when the objects disappear, the model
still remains coherent: for example, the textual attributes
associated with the objects disappear as well.

5. Integration in the environment

Macao’s easy use strongly depends on its integration in
the working environment. i.e. the operating system and
its possibilities to communicate with other programs.
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5.1. Finder informations
The example shown here shows three integration points
with the Finder.

• The formalism name appears below the file name,
• Creation and modifications times are maintained,
• Here, the version field contains the creator of the

document. If you fill the version attribute in the
node information, the entered value will appear in
the window shown.

5.2. Stationery pad
The Macintosh Finder allows you to create stationery
pads. Stationery pads documents are special documents
that the user creates as templates.

When you open this document (see icon on the left),
Macao creates a copy of the document for you to modify.
The original document remains unchanged.

5.3. Help balloons
Introduced with Apple’s System 7, help balloons give the
user access to a unified on-line help for applications.
Macao incorporate this help into all of its menus and dia-
log boxes. Not only do the help balloons define the menu
actions, they also explain why a menu is temporarily dim-
med.

5.4. Copy to another application
Since Macao is not a general graphics application, it must
provide a flexible interface with other general programs
such as ClarisDraw. Copying and pasting is possible from
Macao to ClarisDraw.

In an internal manner, ClarisDraw interprets “Quic-
kDraw” commands that permit the drawing of Bezier cur-
ves and a certain number of “QuickDraw comments” that
permit the grouping of objects. Macao transmits these
comments and can group the objects logically with their
attributes. The roundness of angles is also traced with res-
pect to the users’ habits.
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5.5. Printing
Macao, like all programs on the Macintosh, gives you the
choice of printing formats. 

Printing formats and reduction/enlargement on
LaserWriters can be seen by dotted lines indicating page
limits. The printing format is preserved from one session
to another in the saved document.

You can choose any range of pages or the whole docu-
ment to be printed, and you can have Macao print any
number of copies. Page numbering is from left to right
and then from top to bottom. When you ask to print all
pages, Macao does not print those that are blank. If you
choose Destination File, you can produce a PostScript or an
EPS File

In the next chapter, we’ll see how to use Macao in the AMI
environment.
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Macao in AMI

6. Introduction

The MARS project (Methods and Analysis for Reliable
Systems) is intended to elaborate on a method of deve-
loping parallel computer systems. Macao’s user interface
as well as the AMI (Analysis, Modeling and Integration)
environment have been developed in the interest of this
project.

Macao is more than a simple graph editor. It offers a user-
friendly homogenous interface for accessing and execu-
ting application programs in the AMI environment. These
application programs are seen as services offered to the
user.

A service is a manipulation that can be carried out on a
graph. It allows the user to design a specific action and to
apply it to the model. A service is carried out by an appli-
cation.

A session corresponds to the execution of a service on a
model. The session is a dynamic notion while the service
is static.

7. Open a connection

There are two ways to connect Macao to the AMI environ-
ment: by serial line protocol or by TCP/IP.

7.1. Serial line connection
The first connection method is point to point using a serial
line between the Macintosh and a Unix machine. This con-
nection is very useful as it can be implemented in just
about all Unix environments. It allows Macao to be used
in a minimal environment composed of one Unix station
and one Macintosh (no Ethernet network or Gateway).

7.1.1. Choose the communication parameters
The menu shown here is a hierarchical menu of the item
Connection of the AMI menu.
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After having regulated the transmission speed (19200
bauds is recommended) select the Modem Port item.

The service window takes the name Modem Port and beco-
mes a Unix tty terminal window. All the characters typed
in the window are thus sent to the Unix machine.

Note: The serial line connection allows Macao usage by
modem. The communication protocol efficiently manages
this type of liaison.

7.1.2. Unix AMI connection
The Unix AMI environment will give the user access to a
set of services. In this version of Macao, the user must
connect to the Unix system with a login and password.

Connection example: The service window behaves like a
standard Unix window. In the example below, the user
with login jlm connects to the Sun computer hermes.

hermes login: jlm
Password:
Last login: Sun Apr. 8 14:12:10
SunOS Release 4.0.3c
/hermes/jlm
hermes%

To enter into communication with the AMI server, choose
the item Run Server in the AMI menu.

7.2. TCP/IP connection
The second connection method in a distributed environ-
ment is the TCP/IP connection. This has been implemen-
ted using MacTCP(1). To use it, you need either a
LocalTalk network and a localtalk/ethernet gateway or a
macintosh directly connected on ethernet.

When you choose TCP item in the sub-menu Connection, a
message contacting IP-address appears in the service
window.

8. Register

To use Macao in AMI, you have to register your copy the
first time you use it. Send a mail to:

ami-register@masi.ibp.fr

or a fax at (+33) 01 44 27 62 86 telling us:
i. Your name,
ii. Company,
iii. IP Address of the Sun used for AMI,
iv. HostID of this Sun.

(1) or TCP/IP Control Panel. Macao have been tested under Open Transport 1.1
(Mac OS 7.5.3) but it does not use the Open Trasport API.
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You will receive a password for Macao and for services in
AMI. These passwords allow you to run Macao and AMI
for a certain amount of time and for unlimited copies of
Macao. Without any password, you can still work with
Macao standalone.

Choose About Macao in the Apple menu and click on the
Register(2) button, fill the differents fields and click Quit.

9. Open a session

The user must be identified under both connection
methods Since a simple TCP/IP connection does not iden-
tify a user (anyone is allowed to connect to a TCP port),
the user’s name and password are sent to AMI and the
services are run under her/his unix account. The serial
connection follows the normal Unix login procedure and
thus the user is identified.

You have to give your AMI name (which can be different
from your Unix account) and your password (at least five
characters). Bullets (•) appear instead of letters.

The following message will appear in the service window:

contacting AMI (CPN-AMI 1.x) at <ip number>
The user has been identified by server-name.
The communication is opened with AMI 1.6.

In case of a problem contact your AMI administrator or
cpn-ami@masi.ibp.fr.

10. Run a service

A new menu Services appears in the menu bar.

This menu groups together every question you can ask
AMI with your model. It unifies the services access.

If you haven’t analysed the model before, the Service
menu only contains the item Verification.

The verification consist of the analysis of your model indi-
cating syntactic or semantic errors.

(2) If the button Register does not appear, hold down the option key before
choosing the About Macao item.



Ask a question

34 Macao in AMI © 1988-96

When the verification is finished, or you have already
verified, the Verification item is replaced by every question
you can ask for the model. The menu depends on the class
of the model (here place-transition or colored Petri net).

10.1.Ask a question
When you choose an item in the Service menu, a tempo-
rary floating window appears telling you that the service
is running.

In this window a grey bar will indicate the data transmis-
sion from Macao to AMI. Different messages will also tell
you what is going on in the service.

For some services, it is possible to stop the question with a
Stop button.

10.2.Write lock
When a question is being asked, the user should not
modify the graph. Otherwise, the result will not make any
sense.

More precisely the user is not allowed to make syntactic
modifications. He can do aesthetic modifications because
the services aren’t inflenced by aesthetic modifications
(moving objects, changing fonts,…).

The pencil icon changes indicating that the user must not
modify the model. See the figure on the left.

11. Results of a service

The results of the services depend upon which questions
are asked. It is therefore recommended that you read the
user manuals specific to each service.
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Some services need additional parameters while running.
These services ask the user for new parameters with stan-
dard dialog boxes.

Dialog boxes examples:

or

When results have been computed, they are sent to the
user interface either in a textual or a graphic way.

11.1.Textual results
Textual results appear in the service window. To get more
information while receiving the results, check the item
Detailed Results from the AMI menu before asking for the
question.

11.2.Graphical results
A service may modify or create objects in the original
model or in a new result model(3).

If you have asked for detailed results, Macao will explain
every operation in the service window: creating objects,
deleting objects, explaining every step of the service. You
can copy this text and paste it into you favourite word
processor.

(3) To use this result for another service, you have to save it with another name
(item Save As… from the File menu). It will become a new model for a
service.
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11.3.Results window
When the result of a service consists of showing objects
and modifying textual attributes, Macao groups these
results in a result Window.

In the above example, the window gives you the results of
the P-Flows service. It indicates that the result is composed
of five flows and that the first one is actually shown on the
screen (1/5). If you click on the small white arrow in the
bottom part of the window, Macao will show the second
flow. The text in the window is the name of the places and
they are highlighted in color (on a color screen) in the
model window.

If you want to get a textual description of results, clic in
the middle of the result window. The textual description
will be copied in the service window.

It is therefore recommend that you read the user manuals
specific to each service to interpret the results.

12. End of session

A any time, the user may want to leave Macao. This can
be done by choosing Quit in the File menu. If a service is
running, (s)he is asked to Stop or to Carry out  the service
on the Unix station.

If you’ve made changes since last saving any model, a dia-
log box reminds you to save those changes before Macao
closes.
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Appendix

1. Release Notes

Since version 2.4:
• Improved read file speed.
• Improved floating window handling.
• Improved dialog handling (dimmed, fead-back).
• Duplicate command added.
• Improved scaling.
• Multiple open file from the finder.
• Stationery aware.
• Aliases aware.
• Help balloon aware.
• Core AppleEvent aware.
• New file when opening directly from a formalism

file in the finder.
• Saving in tempory item folder.
• A bug in saving in the incorrect folder was fixed.
• Improved interactive dialogs for some services.
• Clean up for PowerPC.
• MAE 1.0 support.
• Compatibility Copy/Paste with Microsoft Word 5.1

has been improved.
• Other minor bugs fixed.

Since version 2.5:
• Text Styles in attributes.
• Changing multiple objects sizes.
• Better object routing.
• MAE 2.0 support.
• Some Text Drag and Drop.
• Some hierarchical formalisms
• Saving windows position and size.
• Many minor bugs fixed.
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This Macao manual was written, edited, and composed
on a desktop publishing system using Apple Macintosh
computers and FrameMaker software.

Every brand or product names are trademarks or registe-
red trademarks of their respective holders.
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